Unable to install any version of Windows

Hi,

I am donating my MH x230 to a school kid. Unfortunately, windows is required. I tried installing XP, Windows 7, and Windows 10 and all three fail to boot from USB.

Is there something that needs to be done in coreboot settings to get windows installed on this liberated coreboot laptop?

I have been able to throw every version of Linux and even all the BSDs on this laptop with zero problems. I am guessing the coreboot BIOS is missing the proprietary ACPI extensions in the BIOS that Windows requires, which is probably missing in coreboot?

Any advice or pointers would be appreciated

Hi @rsriniva,

What’s happening is that the Windows USB boot image assumes that you will have a computer with an UEFI Bios. What we have with LC230 with Coreboot is they would call a “legacy BIOS”. That could be one reason why the USB does not boot up.

I think once the Windows installer is able to boot up, it would install just fine. The issue now is how to boot the installer without UEFI.

One quick thing you could try out is to boot the Windows installer using Ventoy.

Download Ventoy on your GNU/Linux installation. The Ventoy download page provides binary releases that you could just use. The same is available from their Github repository: Releases · ventoy/Ventoy · GitHub

Install Ventoy to an empty USB disk. Then just copy the Windows ISO image to the USB disk and boot the computer using USB disk. It should show you an option to boot the Windows ISO. I think the Windows ISO would boot fine that way.

Ventoy is essentially Grub2 with a set of scripts that search the USB for image files and present them in a boot menu for you to choose. The Mostly Harmless USB Disk is built using Ventoy. I could send you a unit and you use that too.

I have personally never tested this out but hopefully the Ventoy approach will work. Will look forward to your feedback.

Also check out this page: How to install Windows in Legacy mode - fit-PC wiki

Another option could be to give the computer to the school kids with GNU/Linux installed on it. If you just show them once, they might be able to learn how to do everything they need to do without Windows too. That might help them explore and learn a whole lot more.

If you need help with this aspect, I would be glad to pitch in whenever any help is needed to teach to something that is GNU/Linux related. :slight_smile:

There are two more things we could do:

  1. Reflash Coreboot on the laptop with Tianocore instead of SeaBIOS. Tianocore is a free software UEFI implementation and that could be one way to have operating systems that expect a UEFI BIOS boot up.

    I haven’t worked on compiling Coreboot with Tianocore in place of SeaBIOS but would be glad to try it out if you wish.

  2. It always possible to flash the original Lenovo Firmware back to the chip. Flashing the default Lenovo firmware would require us to use a flashing clip. But it will work.

    The Atheros wireless card wouldn’t work with the Lenovo BIOS since they have a list of allowed wireless cards and it won’t boot up if it find anything else in its place. But I can send you an Intel Wireless card that ships with the laptop by default and then you would be able to install the OS as usual.

1 Like

Ventoy worked great! Thanks abhas.